Si en B16 efectuamos la comparación =SI(IZQUIERDA(A2;2)=DERECHA(A12;2);”VERDADERO”;”FALSO”) el resultado sería: